
One-Way Analysis of Covariance  
(One-Way ANCOVA) 

 
The ideal method of adjusting for possible extraneous variables is to randomly assign participants 
to the treatment conditions.  

• Eliminates all pre-existing group differences  
• Not always possible, ethical, or feasible 

 
 
 
The researcher may statistically control for one or more extraneous variables by including them 
as covariates in the analysis.  

• Does not eliminate all pre-existing group differences, just those included as covariates 
• Matching groups on one dimension may mean you are creating differences along a second 

dimension. 
 
 
 
One-Way ANOVA Research Questions 
 

 Is gender (female, male) a significant predictor of salary? 
 Can we predict students’ reading scores using type of school system (public, private)? 

 
One-Way ANCOVA Research Questions 
 

 Is gender (female, male) a significant predictor of salary when controlling for years of experience? 
 Can we predict students’ reading scores using type of school system (public, private) after adjusting 

for total household income of the parent(s) and the average age of the parents? 
 
 
Examples of ANCOVA Designs 
 
One-Way ANCOVA  

• One independent variable (between-
subjects) 

• One dependent variable 
• One or more quantitative covariates 

 
Two-Way ANCOVA 

• Two independent variables(between-
subjects) 

• One dependent variable 
• One or more quantitative covariates 

 

One-Way Repeated Measures ANCOVA  
• One independent variable (within-subjects) 
• One dependent variable 
• One or more quantitative covariates 

 
Two-Way Repeated Measures ANCOVA 

• Two independent variables (1 or both may 
be within-subjects) 

• One dependent variable 
• One or more quantitative covariates 
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The Reduced Model is Y X eij ij ij= + +μ β  
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The slope and the intercept are calculated by ignoring group membership. 
 

Slope Calculation for the REDUCED MODEL 
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The Reduced Model is: 
 
 
 

Predicted Scores & Errors for the REDUCED MODEL 
Yij  Xij  Predicted Y 
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 The Full Model is   Y X eij j ij ij= + + +μ α β  

 
The Full Model has a single slope parameter, but allows for an effect of the treatment variable.   
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Thus, the Full Model in the ANCOVA allows the intercepts of the regression lines to vary with each 
group, but the slope parameter is the same for each group.   
 

Slope Calculation for the FULL MODEL 
Yij  Xij  ( )Y Yj−  ( )X X j−  ( )X X j− 2  ( ) * ( )Y Y X Xj j− −  
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( ) =−==+ 222 practice structuredfor intercept ˆˆ XSlopeYαμ   
 
 
 
The Full Model for unstructured practice is:   
 

 
 

 
The Full Model for structured practice is: 
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Predicted Scores & Errors for the FULL MODEL 

Yij  Xij  Predicted Y 
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Interpretation 
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Calculation of Adjusted Means (Use the Slope from the Full Model) 
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Pairwise Comparisons with ANCOVA 
 

F  Statistic for Pairwise Contrasts on the Adjusted Means 
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Bonferroni and Sidak Methods for the Adjusted Means Are Available in SPSS. 
 
⇒ Analyze ⇒ General Linear Model ⇒ Univariate ⇒ Options ⇒ Compare Main Effects  
⇒ Confidence Interval Adjustment ⇒ Sidak 
 
Hand calculations will be required if you want to use the Tukey or Scheffe methods. 
 
1. Have SPSS generate the adjusted means and standard errors. 

 
⇒ Analyze ⇒ General Linear Model ⇒ Univariate ⇒ Options ⇒ Compare Main Effects  
⇒ Confidence Interval Adjustment ⇒ LSD (none) 

 
 

2.  Calculate 
2

Error Std.
DifferenceMean 

⎟
⎠
⎞

⎜
⎝
⎛=F  for each pairwise comparison.  

 
 
 
3. Find the appropriate Tukey or Scheffe F critical value. Use denominator df = N – a - # covariates.  
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ONE-WAY ANCOVA: Is type of school system (public, private, university) a significant 
predictor of children’s math scores after adjusting for the highest education level of the parent(s)? 
 
SPSS Instructions 
→ Analyze →General Linear Model→Univariate 
          Dependent Variable: Math 
          Fixed Factors: School 
          Covariate: Educ 
          √ Estimates of Effect Size 
          √ Descriptive Statistics 
          →Options 
              Display Means For: School 
              √ Compare Main Effects 
              Confidence Interval Adjustment: Sidak 
 
Univariate Analysis of Variance 

Between-Subjects Factors
  Value Label N 
school 1.00 public 15

2.00 private religious 15
3.00 university school 15

 
Descriptive Statistics

Dependent Variable:math score 
school Mean Std. Deviation N 
public 50.8667 12.05859 15
private religious 63.1333 11.64883 15
university school 71.8000 14.43804 15
Total 61.9333 15.20526 45
 

Tests of Between-Subjects Effects
Dependent Variable:math score 

Source 
Type III Sum 

of Squares df Mean Square F Sig. 
Partial Eta 
Squared 

Corrected Model 3486.333a 3 1162.111 7.126 .001 .343
Intercept 5965.228 1 5965.228 36.578 .000 .471
educ 167.400 1 167.400 1.026 .317 .024
school 1767.881 2 883.941 5.420 .008 .209
Error 6686.467 41 163.085    
Total 182781.000 45     
Corrected Total 10172.800 44     
a. R Squared = .343 (Adjusted R Squared = .295) 
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Estimated Marginal Means 
 
school 

Estimates
Dependent Variable:math score 

school Mean Std. Error
95% Confidence Interval 

Lower Bound Upper Bound
public 52.419a 3.636 45.076 59.761 
private religious 62.959a 3.302 56.290 69.627 
university school 70.423a 3.567 63.220 77.626 
a. Covariates appearing in the model are evaluated at the following 
values: years educ. of parent = 18.8222. 
 
 

Pairwise Comparisons
Dependent Variable:math score 

(I) school (J) school 

Mean 
Difference (I-

J) Std. Error Sig.a 

95% Confidence Interval for 
Differencea 

Lower Bound Upper Bound
public private religious -10.540 4.965 .115 -22.898 1.819

university school -18.004* 5.487 .006 -31.662 -4.346
private religious public 10.540 4.965 .115 -1.819 22.898

university school -7.464 4.812 .338 -19.442 4.513
university school public 18.004* 5.487 .006 4.346 31.662

private religious 7.464 4.812 .338 -4.513 19.442
Based on estimated marginal means 
a. Adjustment for multiple comparisons: Sidak. 
*. The mean difference is significant at the .05 level. 
 
 

Univariate Tests
Dependent Variable:math score 
 

Sum of Squares df Mean Square F Sig. 
Partial Eta 
Squared 

Contrast 1767.881 2 883.941 5.420 .008 .209
Error 6686.467 41 163.085    
The F tests the effect of school. This test is based on the linearly independent pairwise 
comparisons among the estimated marginal means. 
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Statistical Effect of Including a Covariate in the Model 
 
• Randomized Study – substantially reduces the unaccounted-for variance – leading to a more 

powerful test of group differences 
 
• Nonrandomized Study – reduces the unaccounted-for variance AND answers the question ‘Would 

the groups differ on the dependent variable if they had been equivalent on the covariate?’ 
 
Assumptions for the ANCOVA Model:  ijijjij eXY +++= βαμ  

 
1. The error scores eij are independently distributed. 
2. The error scores eij are normally distributed. 
3. The error scores eij have an expected value of zero and a constant variance. 
 
Implications of Assumptions 
 
1. The conditional distribution of Y must be normally distributed if eij  is normally distributed. 
 
2. The relationship between Y and X is presumed to be linear. If there is reason to suspect a polynomial 

relationship between Y and X then you can use regression to determine the appropriate way to model 
the covariate. See page 9 for instructions.  

 
3. The separate within-group regression lines have the same slope because β is pooled across the 

groups. 
 

This assumption may be explicitly tested. See page 10 for instructions. You hope for a 
nonsignificant test…which would indicate the slopes are homogenous. 
 
If the test is significant, one of the following strategies may be used. 
 

• Conduct a one-way ANCOVA that allows heterogeneous slopes. Currently, the 
GLM procedure does not support it. Hand calculations would be required, but 
SPSS could be used to obtain most of the necessary information. See Maxwell 
and Delaney for more information.  

 
• One could also transform the covariate to a factor that has a few discrete levels 

and conduct a two-way ANOVA (see blocking information at the end of the 
notes) instead of a one-way ANCOVA. For example, school (public, private, 
university) X parent education (HS, BS, MS, PHD) would be the factors and math 
scores would be the dependent variable. 

 
 

4. The covariate values are assumed to be fixed, not random. That is, statistical inferences can be 
made only to the Y values expected at the particular X values included in the study. 
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Nonsignificant ANOVA 
 
 
 
 
 
 
 
 
 
 

 Significant ANCOVA, quadratic covariate 
 
 
 
 
 
 
 
 
 
 
 

   
Significant ANOVA 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Significant ANCOVA, homogeneous (equal) 
slopes 
 

   
Nonsignificant ANCOVA 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Significant ANCOVA, heterogeneous 
(unequal) slopes 
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TEST FOR POLYNOMIAL RELATIONSHIPS 

SPSS Instructions 
→Analyze→Descriptive Statistics→Descriptives 
                Variables: EDUC 

Descriptive Statistics 
 N Minimum Maximum Mean Std. Deviation 

years educ. of parent 45 6.00 29.00 18.8222 4.96940 

Valid N (listwise) 45     

 
SPSS Instructions 
→ Transform → Compute Variable 
                Target Variable: QUADEDUC 
                Numeric Expression: (educ-18.82)*(educ-18.82) 
→ Analyze → Regression → Linear 
                Dependent: MATH 
                Independents: EDUC, QUADEDUC 
Regression 

Variables Entered/Removed

Model Variables Entered 
Variables 
Removed Method 

1 quadeduc, years 
educ. of parenta 

. Enter 

a. All requested variables entered. 
 

Model Summary

Model R R Square Adjusted R Square
Std. Error of the 

Estimate 

1 .416a .173 .133 14.15443
a. Predictors: (Constant), quadeduc, years educ. of parent 
 

ANOVAb

Model Sum of Squares df Mean Square F Sig. 

1 Regression 1758.195 2 879.097 4.388 .019a

Residual 8414.605 42 200.348   

Total 10172.800 44    
a. Predictors: (Constant), quadeduc, years educ. of parent 
b. Dependent Variable: math score 
 

Coefficientsa

Model 

Unstandardized Coefficients 
Standardized 
Coefficients 

t Sig. B Std. Error Beta 

1 (Constant) 39.607 8.882  4.459 .000

years educ. of parent 1.223 .436 .400 2.804 .008

quadeduc -.029 .065 -.064 -.445 .658
a. Dependent Variable: math score 
 
  



ANCOVA, 11 
TEST FOR HOMOGENOUS SLOPES 

SPSS Instructions 
→ Analyze →General Linear Model→Univariate 
          Dependent Variable: Math 
          Fixed Factors: School 
          Covariate: Educ 
          →Model 
                  √ Custom 
                          Model:  School, Educ, School*Educ 
 
 
Univariate Analysis of Variance 

Between-Subjects Factors 

  Value Label N 

school 1.00 public 15

2.00 private religious 15

3.00 university school 15

 
Tests of Between-Subjects Effects 

Dependent Variable:math score 

Source 

Type III Sum of 

Squares df Mean Square F Sig. 

Corrected Model 3674.441a 5 734.888 4.410 .003 

Intercept 5155.932 1 5155.932 30.943 .000 

school 207.778 2 103.889 .623 .541 

educ 41.502 1 41.502 .249 .621 

School * educ 188.108 2 94.054 .564 .573 

Error 6498.359 39 166.625   

Total 182781.000 45    

Corrected Total 10172.800 44    

a. R Squared = .361 (Adjusted R Squared = .279) 
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Group Differences in the Covariate: Problems in Interpretation 
 
If the groups differ on the covariate, then interpretation of the results may be ambiguous. The ideal 
situation is for the groups to be similar on the covariate (i.e., nonsignificant test). The instructions for 
testing are shown on page 12.  
 
Situations where Dependence occurs between the Treatment and Covariate 
 
Case I:  Fluke Random Assignment.  Subjects were randomly assigned to groups and the covariate 
differs across groups because of chance variability.  Thus, the rejection of the hypothesis is a type I 
error.   
 
• This situation may be avoided by performing stratified random sampling.   
• Regardless, it is acceptable to interpret ANCOVA when the dependence is caused by chance. 
 
 
Case II:  Biased Assignment Procedure.  Subjects were assigned to treatment groups on the basis of their 
covariate scores. (e.g., if IQ < 100 headstart, else traditional schooling).   
 
• The assumptions of ANCOVA must be met if the subjects were assigned to groups on the basis of 

their covariate scores.  Heterogeneous slopes are likely.  
 

 
Case III:  Treatment Affects the Covariate.  If the subjects’ scores on the covariate are obtained after the 
onset of the treatment, then the covariate scores may be influenced by the treatment effect.   
 
• It is very difficult to interpret the ANCOVA results because adjusting for the covariate also adjusts 

for the treatment effect!  
• Generally, we do not interpret the ANCOVA in this situation. 
 
 
Case IV:  Non-Random Assignment of Subjects to Groups.  If the design is really a quasi-experiment and 
not a true experiment, then the groups are pre-existing. 
 
• We can only interpret the results as being correlational and not causational.   
• Using ANCOVA to adjust for differences in the pre-existing groups may also artificially induce 

differences on other variables.   
• Adjusting for one covariate does not eliminate any other covariates that might influence the pre-

existing groups. 
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TEST FOR GROUP DIFFERENCES ON THE COVARIATE 
SPSS Instructions 
→Analyze→Compare Means→One-Way ANOVA 
 Dependent List: EDUC 
 Factor: SCHOOL 

→Options 
 √ Descriptives 
→Post Hoc 
 √ Tukey   …or another procedure 

 
Oneway 

Descriptives 
years educ. of parent 

 

N Mean Std. Deviation Std. Error

95% Confidence Interval for 
Mean 

Minimum Maximum Lower Bound Upper Bound 

public 15 15.4667 4.18956 1.08174 13.1466 17.7868 6.00 21.00
private religious 15 19.2000 5.38782 1.39113 16.2163 22.1837 9.00 29.00
university school 15 21.8000 3.05193 .78801 20.1099 23.4901 17.00 26.00
Total 45 18.8222 4.96940 .74079 17.3292 20.3152 6.00 29.00

 
ANOVA 

years educ. of parent 

 Sum of Squares df Mean Square F Sig. 

Between Groups 304.044 2 152.022 8.159 .001 
Within Groups 782.533 42 18.632   
Total 1086.578 44    
 
Post Hoc Tests 

Multiple Comparisons 
years educ. of parent 
Tukey HSD 

(I) school (J) school 
Mean Difference 

(I-J) Std. Error Sig. 

95% Confidence Interval 

Lower Bound Upper Bound 

public private religious -3.73333 1.57614 .057 -7.5626 .0959

university school -6.33333* 1.57614 .001 -10.1626 -2.5041
private religious public 3.73333 1.57614 .057 -.0959 7.5626

university school -2.60000 1.57614 .237 -6.4292 1.2292
university school public 6.33333* 1.57614 .001 2.5041 10.1626

private religious 2.60000 1.57614 .237 -1.2292 6.4292
*. The mean difference is significant at the 0.05 level. 
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Other Statistical Methods of Adjusting for Covariates 
 
Analysis of Residuals 

• Regress the dependen variable on the covariate to obtain predicted values and prediction errors 
(residuals).  

• Conduct a one-way ANOVA where the new dependent variable is the prediction errors from the 
regression model. 

 
• This results in a test statistic that is not properly distributed. It is not recommended. See Maxwell 

and Delaney (2004) for more details. 
 
Analysis of Gain Scores 

• If the dependent variable and the covariate are measured on the same scale (e.g., pretest score = 
covariate, posttest score = dependent variable), then a gain score = posttest – pretest may be 
calculated. 

• Conduct a one-way ANOVA where the gain scores are the dependent variable in the analysis. 
 

• Randomized Design – the ANCOVA approach is almost always preferred because it is a more 
powerful test. The one advantage that gain scores have over ANCOVA is the slope parameter 
does not have to be estimated, so the gain score approach has 1 more degree of freedom. 
 

• Nonrandomized Design – the ANCOVA and ANOVA with gain scores do not test the same 
hypothesis.  When the ANCOVA question is not of interest, then the analysis of gain scores may 
be more appropriate.  

 
ANOVA with Blocking 

1. The continuous covariate is transformed into an additional factor with discrete levels (e.g., 
dichotomized). 

2. Then, a two-way ANOVA would be conducted. One factor represents the IV for the research 
study; the other factor represents the covariate. The primary research question would still be the 
test of the independent variable.  

3. The ANCOVA is generally preferred. ANCOVA uses fewer degrees of freedom and information 
about the covariate is not lost through converting it to discrete levels.  

 
 


